Skocz do zawartości
ATOMIZER

Wzmacniacz 2x15w

Recommended Posts

Witam!

Od dziś jestem nowym uczestnikiem forum, zarejestrowałem się aby otrzymać fachową pomoc i doradztwo.

Próbuję zbudować przenośny głośnik niewielkich rozmiarów o mocy 2x15w do słuchania muzyki z telefonu za pośrednictwem bluetooth.

Obecnie posiadam mały głośniczek bluetooth o mocy 3w zasilany 5v 500mAh, ale na 70%mocy dziwnie charczy i trzeszcz nie gra czysto jak jest głośniej. Dlatego chcę zbudować coś większego i w dodatku stereo. Tak jak widać zima, zimno nie chce się wychodzić z domu to można coś podłubać wieczorem.

Zakupiłem kilka niezbędnych podzespołów z kilka zł.

Wzmacniacz 2x15W PAM88610 - Class-D stereo

Przetwornica DC-DC - MT3608 2A 4-28V - Step-Up - podnosząca napięcie ( niestety uległa spaleniu )

Przetwornica LM2577 2A z USB - STEP-UP - napięcie regulowane 5-28V

Moduł Odbiornika Bluetooth Audio - 5V - do głośnika bezprzewodowego DIY

Akumulatory Li-Ion 18650

Zasilacz buforowy - Ładowarka Micro USB 1A do Li-pol 18650 - na TP4056

Głośniki 2 x Monacor SP-8/4SQ, głośnik uniwersalny obecnie testuje głośniki 2 x YD40 -17 4-OHM h=17mm 3W

Wydaje mi się, że mam wszystko co potrzebne do zrobienia głośnika, poszukałem w internecie i obejrzałem kilka filmów na YOUTUBE i odniosłem wrażenie, że jest to bardzo proste poskładać wszystko w całość i będzie ładnie grac tak jak na filmikach z internetu.

Przystąpiłem wiec do montażu...

Na początku przylutowałem na wzmacniaczu złącza goldpin, podłączyłem głośniki, zasilanie i źródło dźwięku ( na początku przez wtyk jack 3,5mm ) zrezygnowałem z modułu bluetooth ponieważ nie znalazłem dokładnej instrukcji jak wszystko podpiąć aby zadziałało.

No i o dziwo urządzenie nie gra tak jak się spodziewałem po obejrzeniu kilku filmików instruktażowych z internetu.

Po pierwsze głośnik L bardzo głośno charczy! Głośnik R OK ( na pierwsze próby podłączyłem dwa głośniki 3w )

Na początku zasilałem pakietem li-pol 3S 11,2V + przetwornica DC-DC - MT3608 2A 4-28V - Step-Up - podnosząca napięcie na której ustawiłem 12V na OUT

Po włączeniu wzmacniacz może działa jakieś 0,5s i przestaje grać... po 100 próbach spaliła się przetwornica! Wiec podłączyłem do baterii 9V i wszystko zaczęło lepiej działać!

Oba głośniki grały z tym, że głośnik L głośniej szumi niż gra czysto głośnik R...! W dodatku jak chcę zrobić głośniej to urządzenie się wyłącza??? Max. 1/3 głośności, która ustawiłem na telefonie, jedna kreseczka głośności wyżej i przestaje działać ? Hmmmm... podłączyłem wzmacniacz do zasilacza laboratoryjnego na którym ustawiłem równo 12V i nie gra! Po kilku próbach doszedłem do wniosku, że wzmacniacz gra od 6-8V na maksymalnie 1/3 głośności ustawionej w telefonie. Mniejsze lub większe napięcie powoduje natychmiastowe przestanie w działaniu. Być może dlatego wzmacniacz grał na baterii9V częściowo rozładowanej a na przetwornicy gdzie było ustawione OUT 12V nie...

Muszę powiedzieć, że jestem w tym kompletnie zielony, jak do tej pory budowałem tylko samoloty rc których zrobiłem ok,. 40

Po obejrzeniu kilku filmików wydawało się to bardzo proste.

Wklejam jeszcze kilka zdjęć z prób...

Może ktoś będzie w stanie pomóc?

20190110_221157.jpg

20190110_221216.jpg

20190110_221225.jpg

20190110_221234.jpg

20190110_221243.jpg

20190110_221306.jpg

20190110_221316.jpg

20190110_221325.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Główny problem jaki tu widzę na zdjęciach, to taki że głośniki powinny mieć jakieś obudowy. Bez tego trudno mówić o jakimkolwiek ich graniu, a szczególnie o głośnym ich graniu bo fale z obu stron membrany są w przeciwnej fazie i się znoszą. Druga sprawa polega na tym ze jeśli chcesz zasilać wzmacniacz z przetwornicy, to napięcie takie powinno być filtrowane. Bez tego łatwo nawet uszkodzić taki wzmacniacz.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Przypomniały mi się młodzieńcze lata. Zero Internetu, Youtube'ów. Tylko książki i Młody Elektronik. Starsi mówili mi wtedy, że większość układów za pierwszym razem nie działa. Może na początek sprawdź poprawność lutów, przyłóż się do nich bo cyna aż kipi.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

No witam ?

Tak jak widzicie lutownice trzymałem może 3 raz w ręku ? ale to dobry pomysł na zimowe wieczory aby czegoś się nauczyć i poprawić swoje zdolności manualne.

Wczoraj przyszła kolejna paczka ze sklepu ABC-RC, w której zamówiłem dodatkowe 4 mini wzmacniacze i parę innych zabawek.

Chciałem sprawdzić czy po podłączeniu innego wzmacniacz do mojego zestawienia mini zestawik zacznie grać (Moduł wzmacniacz audio 2x3W 5V PAM8403 - Arduino)

Wklejam zdjęcie... nie ma co krzyczeć na połączenia (luty) zastanawiam się czy są jakieś inne specjalne lutownice, cyna, kalafonia do lutowania takich drobiazgów...

Sam się zdziwiłem jak zobaczyłem po raz pierwszy ten wzmacniacz 2x15w jaki jest malutki, a ten 2x3w jest jeszcze mniejszy!!!

Puściłem muzykę z telefonu i wszystko pięknie gra ?

Całość podłączyłem do zasilacza laboratoryjnego na którym ustawiłem 5V.

Przy podkręcaniu głośności (nawet na max) zestaw się nie wyłącza i gra na całym zakresie, nie ma tez szumów tak jak w poprzednim wzmacniaczu i oba głośniki grają.

Sprawdziłem napięcie, zakres działania wzmacniacza wynosi od 3V do max 5,5V powyżej słyszane są już jakieś dziwne dźwięki z głośników a poniżej 3V się wyłącza.

Podejrzewam, ze poprzednią płytę albo sam uszkodziłem jak lutowałem do niej goldpiny albo jest coś z nią nie tak.

20190111_193924.jpg

20190111_193939.jpg

20190111_194028.jpg

Wczoraj naszkicowałem sobie projekt mojego głośnika, wykonam go prawdopodobnie ze sklejki liściastej 4mm.

20190112_073258.jpg

I schemat ?

Proszę o uwagi i podpowiedzi:

1. Gdzie dać i czy dać? i jakie dać tranzystory, rezystory?

2. Czy włącznik jest w odpowiednim miejscu?

3. Czy moduł naładowania baterii jest w odpowiednim miejscu? i czy to odpowiedni moduł?

4. Jako opcja moduł bluetooth, ale nie wiem jak i gdzie podłączyć do tego moduły zasilanie...

5. I inne...

Głośnik - schemat.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Cisza...

No nic jak coś nie wiesz to szukaj, a internet to wielkie wysypisko śmieci, może czasem coś znajdzie się interesującego i pożytecznego.

W międzyczasie skleiłem obudowę - ręczna robota ?

Zamierzam okleić folią carbon na zdjęciach próbka na kawałku sklejki.

 

1.jpg

2.jpg

3.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Witam po krótkiej przerwie...

Wczoraj trochę pomajstrowałem przy moim głośniku, niestety w weekend nie było czasu, narty...

Okleiłem front głośnika carbonem i zamontowałem głośniki... podłączyłem wszystko w całość wg nowego schematu 1 mini jack 3.5 tak jak na zdjęciu w załączniku, całość zapakowałem do pudełka i wszystko gra ładnie tak jak powinno. Włączyłem muzykę z telefonu gra ładnie i głośno jak na takie małe głośniki... jedyny problem, który zauważyłem to jak przychodzi sms to następuje trzask w głośniku i się wyłącza... ale tylko kiedy głośność jest ustawiona w granicach od 3/4 maksymalnych mocy sprzętu.

I tu mógłbym zakończyć swój głośnik na wtyczkę mini jack 3.5.

20190117_214011.jpg

Głośnik - schemat 1 mini jack 3.5.jpg

Następnie zmontowałem głośnik z modułem bluetooth wg schematu 2 jak na zdjęciu.

Oczywiście głośnik po włączeniu zadziałał i połączył się z telefonem bez jakiegoś problemu, ale wydobywają się dość głośne szumy i trzaski, które powodują, że bolą uszy jak się słucha muzyki.

Może coś źle podłączyłem, czegoś nie dałem... no nie wiem. A może tak ma być, w końcu te moduły kupione za 2,30zł/szt.

Widzę duża ilość odwiedzających ale nikt nić nie pisze...? Może trzeba gdzieś zainstalować jakiś kondensatorek-rezystorek, aby te szumy po prostu znikły ???

20190121_205247.jpg

20190121_205628.jpg

Głośnik - schemat 2 bluetooth.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
21 minut temu, ATOMIZER napisał:

Widzę duża ilość odwiedzających ale nikt nić nie pisze...? Może trzeba gdzieś zainstalować jakiś kondensatorek-rezystorek, aby te szumy po prostu znikły

Hm… Myślę, że tego typu temat wymaga, oprócz oczywiście wiedzy z zakresu elektroniki, dość mocnego wgryzienia się w niego, aby można było coś sensownego doradzić. Przypuszczam, że nawet na forum elektronicznym nie uzyskałbyś na odległość gotowej recepty jak to poprawić. Często bez dokładnego zrozumienia działania układu, możliwości zmierzenie tego czy owego, trudno wyciągnąć jakieś wnioski. Wygląda więc na to, że skazany jesteś na samodzielną walkę z tym "złośliwym" ustrojstwem, a czytelnicy zapewne oczekują, że podzielisz się spostrzeżeniami, gdy rozwikłasz problem :) 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Witam!

Dalej walczymy z projektem...

20190125_071400.jpg

Wczoraj wieczorem chciałem zakończyć już projekt, kupiłem odpowiednie kondensatory 2000uF na 10V ale na nieszczęście spalił się moduł bluetooth, a nie miałem drugiego. Wiec wyprowadziłem mini jacka i wszystko zmontowałem w całość. Głośnik grał przez ok godz. a jak długo wytrzyma na pakiecie li-ion? Tego jeszcze nie wiem. Ładowanie pakietów działa prawidłowo, dziś ma przyjść paczka z podzespołami wiec w weekend jak znajdę czas zainstaluje bluetooth do tego głośnika...

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Witam po weekendzie ?

Wczoraj wieczorem trochę pomajsterkowałem przy głośniku podłączając moduł bluetooth.

Jednak nie osiągnąłem zadowalającego mnie efektu końcowego ale jest on wystarczający jak na pierwszy głośnik tej klasy robiony we własnym garażu.

Być może nie miałem odpowiednich kondensatorów, aby zniwelować szumy do minimum...

Do modułu bluetooth przylutowałem 2200uF 10V

Do lewego głośnika 33uF 5V

Uzyskałem w ten sposób najmniejsze szumy przy największej sprawności urządzenia.

Instalując kondensator 2200uF 10V na jednym z głośników szumy znikły prawie do zera ale głośnik na 2/3 mocy po prostu przygasał.

Zaopatrzę się jeszcze w odpowiednie kondensatory i poeksperymentuję w wolnym czasie...

Wklejam aktualny schemat

Ewentualnie na wypadek uszkodzenia modułu bluetooth zostawiłem kabelek mini jack w głośniku.

W następnym głośniku zamontuje cyfrowy wskaźnik napięcia bez tych śmiesznych przełączników???

Rys. 1.jpg

Pora zmontować głośnik w całość i może jakiś film na YouTube jak gra... ale to w wolnej chwili

20190128_220940.jpg

20190128_220954.jpg

20190128_221201.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Jak najszybciej odłącz kondensator połączony równolegle z głośnikiem. On robi zwarcie na wysokich częstotliwościach i może uszkodzić wzmacniacz.

Kondensatory czyszczące napięcie włącza się równolegle w torze zasilania a nie sygnału. Z dużymi kondensatorami elektrolitycznymi dobrze jest połączyć równolegle małe wartości kondensatorów foliowych. Duże kondensatory dobrze tłumią tętnienia napięcia. Małe kondensatory suche lepiej pochłaniają szumy z zasilania. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
38 minut temu, MobyDick napisał:

Jak najszybciej odłącz kondensator połączony równolegle z głośnikiem. On robi zwarcie na wysokich częstotliwościach i może uszkodzić wzmacniacz.

Kondensatory czyszczące napięcie włącza się równolegle w torze zasilania a nie sygnału. Z dużymi kondensatorami elektrolitycznymi dobrze jest połączyć równolegle małe wartości kondensatorów foliowych. Duże kondensatory dobrze tłumią tętnienia napięcia. Małe kondensatory suche lepiej pochłaniają szumy z zasilania. 

Tak szybko to się nie da... dopiero jak wrócę do domu ok 18, ale bardzo dziękuję za zwrócenie uwagi...

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Jeśli chcesz ograniczyć ilość wysokich tonów z głośników szerokopasmowych, to zamiast kondensatorów równoległych trzeba włączyć odpowiednio dobraną cewkę lub układ LR . To właśnie w zakresie wysokich częstotliwości najbardziej odczuwamy szumy w dźwięku.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Po zmianie schemat wygląda tak jak w załączniku...przyspawałem szeregowo do każdego głośnika kondensator 22uF 6,3V jak na zdjęciu, a czy gra lepiej...szum dalej jest słyszany a zauważyłem, że im większy kondensator (np. 33uF 5V) to szum mniejszy ale moc muzyczna zestawu spada znacznie i głośnik gra ciszej...

20190129_190705.jpg

Rys. 1.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Taki kondensator włączony szeregowo z głośnikiem tworzy filtr górnoprzepustowy 1-szego rzędu. Teraz głośnik nie przetwarza niskich częstotliwości. Kondensatory elektrolityczne o polaryzacji +/- nie nadają się do tego celu, szczególnie jeśli są na tak niskie napięcie. Teraz przewodzą prąd przemienny bez stałej składowej, co może uszkodzić warstwę dielektryka. Głośnikom to nie zaszkodzi, tylko kondensatory mogą być do wyrzucenia.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Dnia 29.01.2019 o 12:34, MobyDick napisał:

Kondensatory czyszczące napięcie włącza się równolegle w torze zasilania a nie sygnału. Z dużymi kondensatorami elektrolitycznymi dobrze jest połączyć równolegle małe wartości kondensatorów foliowych.

Ja bym dał 100uF elektrolit i 100nF w linię zasilania 5-5,2V (do masy) pomiędzy przetwornicę , a wzmacniacz. Te przetwornice straszne zakłócenia sieją. powinny być oddalone od wzmacniacza, a nawet ekranowane. tak mi się wydaje :) 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
1 godzinę temu, MariuszZ napisał:

Ja bym dał 100uF elektrolit i 100nF w linię zasilania 5-5,2V (do masy) pomiędzy przetwornicę , a wzmacniacz. Te przetwornice straszne zakłócenia sieją. powinny być oddalone od wzmacniacza, a nawet ekranowane. tak mi się wydaje :) 

I co? zadziała? a jak to by wyglądało na schemacie? potrafisz zaznaczyć? pomiędzy przetwornicę , a wzmacniacz/bluetooth mam już jeden kondensator 2200uF 10V bez niego takie szumy lecą że nic nie słychać muzyki...

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

2200 uF przy przetwornicy ( na wyjściu zasilania ) , 100 uF przy module bluetooth ( na wejściu zasilania ) i 100 nF przy wzmacniaczu (na wejściu zasilania). Wszystkie będą połączone razem równolegle przewodami.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Atomizer. Spróbuj tak jak na przerobionym rysunku. Ponadto, dla wzmacniaczy kl.D, tam gdzie dałeś elektrolity przed głośnikami pomyśl o filtrze (pobaw sie w projekt ;) ) stąd filtr

2.jpg

Spróbuj sygnał z BT przesłać ekranowanymi przewodami jak na zdjęciu.

ekran.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Dnia 30.01.2019 o 16:43, MobyDick napisał:

2200 uF przy przetwornicy ( na wyjściu zasilania ) , 100 uF przy module bluetooth ( na wejściu zasilania ) i 100 nF przy wzmacniaczu (na wejściu zasilania). Wszystkie będą połączone razem równolegle przewodami.

nic to nie pomogło...

Wstrętne szumy uciszyłem o połowę robiąc tak jak na schemacie w załęczniku

Rys. 1.jpg

Ale pojawił się problem... najprawdopodobniej dzięki kondensatorowi 2200uF 25V i za pierwszym razem głośnik się nie włącza.

20190203_210652.jpg

20190203_210721.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

To nie jest rozwiązanie. Jak chcesz filtrować przy głośniku spróbuj zaaplikować filtr jak na zdjęciu. Próbowałeś ekranowanym przewodem sygnał z BT do wzmaka połączyć ? 

11.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
32 minuty temu, MariuszZ napisał:

To nie jest rozwiązanie. Jak chcesz filtrować przy głośniku spróbuj zaaplikować filtr jak na zdjęciu. Próbowałeś ekranowanym przewodem sygnał z BT do wzmaka połączyć ? 

11.jpg

Przewód ekranowany czy nie nie ma tu różnicy, odtwarzanie muzyki przez mini jack 3,5 nie ma szumów. Moduł bluetooth je generuje, to słychać jak się puszcza muzykę i jak zaczyna nadawać to na chwilę przed muzyką wylewa się strumień szumów... wystarczy nacisnąć pauzę i po chwili szumy ucichają a słychać tylko ciche pyk pyk pyk...

Nie bardzo rozumiem ten schemat...jak możesz to zaznacz na załączniku (Rys.2)

Rys. 2.jpg

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gość
Odpowiedz...

×   Wkleiłeś treść z formatowaniem.   Przywróć formatowanie

  Only 75 emoji are allowed.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Poprzedni post został zachowany.   Wyczyść edytor.

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Utwórz nowe...