Skocz do zawartości

Tidal Connect na malinie :) ( przykład Moode audio )


Tomasz S.

Recommended Posts

4 godziny temu, yacool napisał:

Ja tu tez robilem "na czuja", a czy sam moode dziala? Odtwarza dzwiek?

Tak, wszystko inne działa - spotify connect, airplay itd. Znalazłem wskazówki Easy, które opisał na innym forum i zrobiłem wszystko od początku - ale niestety bez skutku.
Jutro zrobię czystę instalkę moode i spróbuję jeszcze raz.

Link do komentarza
Udostępnij na innych stronach

  • Odpowiedzi 72
  • Created
  • Ostatnia odpowiedź

Top Posters In This Topic

58 minut temu, smoq123 napisał:

Tak, wszystko inne działa - spotify connect, airplay itd. Znalazłem wskazówki Easy, które opisał na innym forum i zrobiłem wszystko od początku - ale niestety bez skutku.
Jutro zrobię czystę instalkę moode i spróbuję jeszcze raz.

Nie instaluj od nowa bo to nic nie zmieni.

Jakim poleceniem edytowałeś plik usługi ? 

Link do komentarza
Udostępnij na innych stronach

U mnie na moode 6.7.1 Tidal Connect działał od razu po instalacji (DAC podłączony po USB).

Za jakiś czas zainstalowałem moode 7 i ponownie wgrałem Tidal Connect. I przestało działać. W urządzeniach dostępnych jest widoczny, ale nie gra. Cisza. DAC nie dostaje żadnego sygnału.

Wróciłem do moode 6.7.1 i działa.

Link do komentarza
Udostępnij na innych stronach

sudo systemctl edit --full ifi-streamer-tidal-connect.service

 

I wklej mi zawartość pliku, bo w tym co wstawiłeś wcześniej jest błąd przy nazwie DAC po " brak spacji przed \

Dodatkowo źle wpisałeś nazwę dac dodałeś w niej :-

Ma być identyczna jak w pliku devices

Edytowano przez Easy
Link do komentarza
Udostępnij na innych stronach

Może macie jakiś pomysł bo mi sie skończyły, mam tak:

device#0=snd_rpi_hifiberry_dac: HifiBerry DAC HiFi pcm5102a-hifi-0 (hw:0,0)
w pliku zmieniony wpis na:

  --playback-device "snd_rpi_hifiberry_dac: HifiBerry DAC HiFi pcm5102a-hifi-0 (hw:0,0)" \

i błąd:

Feb 18 09:01:10 moode systemd[1]: /etc/systemd/system/ifi-streamer-tidal-connect.service:5: Unbalanced quoting, ignoring: "/usr/ifi/ifi-tidal-release/bin/tidal_connect_

 

Próbowałem zmieniać wpisy np:

  --playback-device "snd_rpi_hifiberry_dac HifiBerry DAC HiFi pcm5102a-hifi-0: - (hw:0,0)" \

albo 

  --playback-device "HifiBerry DAC HiFi pcm5102a-hifi-0 (hw:0,0)" \

i jeszcze innych kilka możliwych wariacji, ale ciągle ten sam błąd

 

Link do komentarza
Udostępnij na innych stronach

4 godziny temu, maroo23 napisał:

Może macie jakiś pomysł bo mi sie skończyły, mam tak:

device#0=snd_rpi_hifiberry_dac: HifiBerry DAC HiFi pcm5102a-hifi-0 (hw:0,0)
w pliku zmieniony wpis na:

  --playback-device "snd_rpi_hifiberry_dac: HifiBerry DAC HiFi pcm5102a-hifi-0 (hw:0,0)" \

i błąd:

Feb 18 09:01:10 moode systemd[1]: /etc/systemd/system/ifi-streamer-tidal-connect.service:5: Unbalanced quoting, ignoring: "/usr/ifi/ifi-tidal-release/bin/tidal_connect_

 

Próbowałem zmieniać wpisy np:

  --playback-device "snd_rpi_hifiberry_dac HifiBerry DAC HiFi pcm5102a-hifi-0: - (hw:0,0)" \

albo 

  --playback-device "HifiBerry DAC HiFi pcm5102a-hifi-0 (hw:0,0)" \

i jeszcze innych kilka możliwych wariacji, ale ciągle ten sam błąd

 

A jakie urządzenie masz w moode w mpd ustawione do odtwarzania ? I jakim poleceniem edytowałeś plik konfiguracyjny usługi ? I po wykonaniu jakiego polecenia pojawia się błąd ? 

Edytowano przez Easy
Link do komentarza
Udostępnij na innych stronach

[Unit]
Description=iFi Streamer Tidal Connect Service
[Service]
Restart=on-failure
ExecStart=/usr/ifi/ifi-tidal-release/bin/tidal_connect_application \
                                --tc-certificate-path "/usr/ifi/ifi-tidal-release/id_certificate/IfiAudio_ZenStream.dat" \
                                --netif-for-deviceid eth0 \
                                -f "DietPi stream to project“ \
                                --codec-mpegh true \
                                --codec-mqa false \
                                --model-name "DietPi Streamer" \
                                --disable-app-security false \
                                --disable-web-security false \
                                --enable-mqa-passthrough false \
                                --playback-device "snd_rpi_hifiberry_dac: HifiBerry DAC HiFi pcm5102a-hifi-0 (hw:0,0)" \
                                --log-level 3
User=root
Group=root
RestartSec=1
KillMode=control-group
[Install]
WantedBy=multi-user.target

Link do komentarza
Udostępnij na innych stronach

Był jeszcze gdzieś skrypt który wszystko instalował sam, jego też puszczałem ale z tym samym efektem, ponieważ na koniec ten driver i tak samemu trzeba wpisać i niestety błąd :/

 

Problemem wydaje mi się jest to że mój Dac podłączony jest przez gpio, nie przez USB i tu gdzieś jest problem 

 

Link do komentarza
Udostępnij na innych stronach

Update:

Przeinstalowałem moode, ponieważ po apt-get upgrade malina sie nie uruchomiła ...

zainstalowałem z tego linku

https://github.com/shawaj/HiTide

nic wiecej nie robiłem i działa :)

Nie ma tego wpisu:

--playback-device "snd_rpi_hifiberry_dac: HifiBerry DAC HiFi pcm5102a-hifi-0 (hw:0,0)" \

Nie ma nawet opcji:

--playback-device

więc o co kaman?

Link do komentarza
Udostępnij na innych stronach

  • 3 weeks later...

Witam,

Mam problem z tą wtyczką na 3B+ z Allo Boss 1.2 i Moode7.0.1. INstalacja przebiegła bez problemów, albo przynajmniej tak wyglądało, bo nie widziałem żadnego błędu. Streamer pojawia się na tel i desktopie, a nawet i gra :). Problem z tym, że przestaje po 30-40 sek. :(

W logach ma to:

Mar 11 20:40:45 moode tidal_connect_application[2084]: STARTED TidalConnect services.

Mar 11 20:41:23 moode tidal_connect_application[2084]: [2021-03-11 20:41:23.212] [tisoc] [warning] [PlaybackControllerImpl.cpp:472] Illegal state:1

Mar 11 20:42:03 moode tidal_connect_application[2084]: [2021-03-11 20:42:03.180] [tisoc] [error] [logger.cpp:25] [operation_curl.cpp:258] curl_easy_perform failed:  Timeout was reached  -  Resolving timed out after 5515 milliseconds

Mar 11 20:42:03 moode tidal_connect_application[2084]: [2021-03-11 20:42:03.180] [tisoc] [error] [logger.cpp:25] [http_stream_fetcher.cpp:162] Content-Range is missing from response!

Mar 11 20:42:08 moode tidal_connect_application[2084]: [2021-03-11 20:42:08.713] [tisoc] [error] [logger.cpp:25] [operation_curl.cpp:258] curl_easy_perform failed:  Timeout was reached  -  Resolving timed out after 5513 milliseconds

Mar 11 20:42:08 moode tidal_connect_application[2084]: [2021-03-11 20:42:08.713] [tisoc] [error] [logger.cpp:25] [http_stream_fetcher.cpp:162] Content-Range is missing from response!

Mar 11 20:42:14 moode tidal_connect_application[2084]: [2021-03-11 20:42:14.246] [tisoc] [error] [logger.cpp:25] [operation_curl.cpp:258] curl_easy_perform failed:  Timeout was reached  -  Resolving timed out after 5515 milliseconds

Mar 11 20:42:14 moode tidal_connect_application[2084]: [2021-03-11 20:42:14.246] [tisoc] [error] [logger.cpp:25] [http_stream_fetcher.cpp:162] Content-Range is missing from response!

Mar 11 20:42:14 moode tidal_connect_application[2084]: [2021-03-11 20:42:14.250] [tisoc] [warning] [logger.cpp:22] [audio_worker.cpp:288] Max connection attempts reached!

Mar 11 20:42:26 moode tidal_connect_application[2084]: [2021-03-11 20:42:26] [info] asio async_shutdown error: asio.misc:2 (End of file)

 

Próbowałem wielu rzeczy, ale bez skutku. 

Mój ifi-streamer-tidal-connect.service:

[Unit]

Description=RasPi Streamer Tidal Connect Service

[Service]

Restart=on-failure

ExecStart=/usr/ifi/ifi-tidal-release/bin/tidal_connect_application \

                                --tc-certificate-path "/usr/ifi/ifi-tidal-release/id_certificate/IfiAudio_ZenStream.dat" \

                                -f "HiTide RasPi Streamer" \

                                --codec-mpegh true \

                                --codec-mqa false \

                                --model-name "HiTide RasPi Streamer" \

                                --disable-app-security false \

                                --disable-web-security false \

                                --enable-mqa-passthrough false \

                                --log-level 3 \

                                --enable-websocket-log "0"

 

User=root

Group=root

RestartSec=1

KillMode=control-group

[Install]

WantedBy=multi-user.target

 

Próbowałem także dodać playback-device "BossDAC: DAC HiFi [Master] pcm512x-hifi-0 (hw:0,0)" dokładnie co wypluła komenda, ale wtedy nawet service new startuje.

Powoli tracę cierpliwość... i nadzieje. Macie może pomysł jak to jeszcze można ugryźć?

 

Więc te "timeouts" zmusily mnie do grzebania w temacie i znalazłem winowajcę. Kilka godzin przed instalacją wtyczki robiłem aktualizacje pfsense do v2.5, która zafundowała nowego bug'a pt. "unbound". Jest to DNS Resolver, którego używam w sieci i po aktualizacji ten proces poprostu pada co minutę i opóźnia zapytania DNS. Opóźnienia nie są do akceptacji przez wtyczkę i stąd timeouts w logach malinki. O dziwo Tidal na kompie i tel toleruje te opóźnienia. Koniec końcem rozwiązaniem była mała modyfikacja na pfsense i Tidal Connect śmiga już jak złoto.

Pozdro

Edytowano przez chopperpl
Naprawione!!!!!
Link do komentarza
Udostępnij na innych stronach

  • 2 weeks later...

Parę dni temu pojawiła się wersja 7.1.0
Kilka osób pisało, że ma problemy z dźwiękiem. Oto moje spostrzeżenia z instalacji Tidala.
Malina 4B + DAC po USB
O ile dobrze pamiętam, 6.7.1 miało domyślne wyjście dźwięku na gniazdo słuchawkowe.
jakimś cudem Tidal znajdował DACa i wszysko działało.
W 7.1.0 domyślnie wychodzi po HDMI. I dlatego, jak pisano wcześniej, wyjście DACa milczy.
Oto jak instalowałem:
url -sSL https://raw.githubusercontent.com/shawaj/HiTide/main/install.sh | sudo bash
sudo systemctl enable ifi-streamer-tidal-connect.service
sudo /usr/ifi/ifi-tidal-release/pa_devs/run.sh
cat  /usr/ifi/ifi-tidal-release/pa_devs/devices
# tu tu szukujemy nazwę naszego DACa i po linii
# --enable-mqa-passthrough false \
# wpisujem ją w cudzysłowach  np coś takiego
   --playback-device "MójDAC: USB Audio (hw:2,0)" \
sudo systemctl edit --full ifi-streamer-tidal-connect.service
sudo reboot         # aby sprawdzić, czy wszystko działa.

Na koniec jeszcze na stronie malinki możemy zmienić wyjście systemowe dźwięku na DAC, aby działało radio internetowe
m -> Configure -> Audio -> MPD Options -> MPD settings -Output device

Link do komentarza
Udostępnij na innych stronach

  • 1 month later...

Zainstalowalem z powodzeniem tidal connect na Moode audio. Ale ciężkie chwile przeżyłem jak posłuchałem Broken Bells Greta Van Fleet zwlaszcza ostatnie minuty - normalnie jakbym miał w głośnikach piach, który skacze po membranie. No ale na szczęście  ten sam kawałek puszczony po BubbleUp gra normalnie. Ktoś też tak ma?

Edytowano przez emeryt
Link do komentarza
Udostępnij na innych stronach

13 minut temu, marcinmarcin napisał:

Ogolnie tak ostro brzmi Tidal vs Deezer 

Ale ja przez BubbleUp streamuje tidala. Więc różnica jest tylko w aplikacji, i ewentualnie tidal connect streamuje jak master a BubbleUp jako hifi. Dodatkowo sprawdziłem tidal przezBubbleUp z runeaudio i z volumio. I problem jest tylko z tidal connect.

Edytowano przez emeryt
Link do komentarza
Udostępnij na innych stronach

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gość
Odpowiedz...

×   Wkleiłeś treść z formatowaniem.   Przywróć formatowanie

  Only 75 emoji are allowed.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Poprzedni post został zachowany.   Wyczyść edytor.

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Utwórz nowe...